re = /Requester\n\n.+\n\n(?<name>.+?)\s\((?<email>[^)\n\r ]+)\)?/m
str = 'Requester
jeff@gmail.com
Loren Goodtree (lg@gmail.com)
To view the completed version, please see the file attached.
Best,
Matt Hernandez
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end