import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "Requester\\n\\n.+\\n\\n(?<name>.+?)\\s\\((?<email>[^)\\n\\r ]+)\\)?";
final String string = "Requester\n\n"
+ "jeff@gmail.com\n\n"
+ "Loren Goodtree (lg@gmail.com)\n\n"
+ "To view the completed version, please see the file attached.\n\n"
+ "Best,\n\n"
+ "Matt Hernandez\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}