const regex = /Requester\n\n.+\n\n(?<name>.+?)\s\((?<email>[^)\n\r ]+)\)?/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('Requester\\n\\n.+\\n\\n(?<name>.+?)\\s\\((?<email>[^)\\n\\r ]+)\\)?', 'gm')
const str = `Requester
jeff@gmail.com
Loren Goodtree (lg@gmail.com)
To view the completed version, please see the file attached.
Best,
Matt Hernandez
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}