using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\.actionBlock\[selected\]\s*{[^{}]+?color:\s*)([^;]+)(;)";
string substitution = @"$1#FFF; /* EDITED : $2 */";
string input = @".actionBlock[selected] {
color: var(--gray11);
background-color: var(--gray11);
}";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}