use strict;
my $str = '.actionBlock[selected] {
color: var(--gray11);
background-color: var(--gray11);
}';
my $regex = qr/(\.actionBlock\[selected\]\s*{[^{}]+?color:\s*)([^;]+)(;)/mp;
my $subst = '$1#FFF; /* EDITED : $2 */';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";