package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(\.actionBlock\[selected\]\s*{[^{}]+?color:\s*)([^;]+)(;)`)
var str = `.actionBlock[selected] {
color: var(--gray11);
background-color: var(--gray11);
}`
var substitution = "$1#FFF; /* EDITED : $2 */"
fmt.Println(re.ReplaceAllString(str, substitution))
}