$re = '/(\.actionBlock\[selected\]\s*{[^{}]+?color:\s*)([^;]+)(;)/m';
$str = '.actionBlock[selected] {
color: var(--gray11);
background-color: var(--gray11);
}';
$subst = "$1#FFF; /* EDITED : $2 */";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;