// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(\.actionBlock\[selected\]\s*{[^{}]+?color:\s*)([^;]+)(;)").unwrap();
let string = ".actionBlock[selected] {
color: var(--gray11);
background-color: var(--gray11);
}";
let substitution = "$1#FFF; /* EDITED : $2 */";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}