import Foundation
let pattern = #"(\.actionBlock\[selected\]\s*{[^{}]+?color:\s*)([^;]+)(;)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
.actionBlock[selected] {
color: var(--gray11);
background-color: var(--gray11);
}
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = ##"$1#FFF; /* EDITED : $2 */"##
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)