# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(\.actionBlock\[selected\]\s*{[^{}]+?color:\s*)([^;]+)(;)"
test_str = (".actionBlock[selected] {\n"
" color: var(--gray11);\n"
" background-color: var(--gray11);\n"
"}")
subst = "$1#FFF; /* EDITED : $2 */"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.