#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)"\$\{([a-zA-Z0-9_.]+)\}""
Local $sString = " "EncryptionOperation": "EnableEncryption"," & @CRLF & _
" "KeyVaultURL": "${data.azurerm_key_vault.disk.0.vault_uri}"," & @CRLF & _
" "KeyVaultResourceId": "${var.key_vault_id}"," & @CRLF & _
" "KeyEncryptionAlgorithm": "RSA-OAEP"," & @CRLF & _
" "VolumeType": "All"" & @CRLF & _
"" & @CRLF & _
" "hostname" = var.host_name" & @CRLF & _
" "description" = var.description" & @CRLF & _
"" & @CRLF & _
"output "network_interface_name" {" & @CRLF & _
" value = "${azurerm_network_interface.nic.id}"" & @CRLF & _
"}" & @CRLF & _
"" & @CRLF & _
" triggers = {" & @CRLF & _
" folders = "${local.folders}"," & @CRLF & _
" container = "${azurerm_storage_container.main.name}"" & @CRLF & _
" }"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")