re = /"\$\{([a-zA-Z0-9_.]+)\}"/m
str = ' "EncryptionOperation": "EnableEncryption",
"KeyVaultURL": "${data.azurerm_key_vault.disk.0.vault_uri}",
"KeyVaultResourceId": "${var.key_vault_id}",
"KeyEncryptionAlgorithm": "RSA-OAEP",
"VolumeType": "All"
"hostname" = var.host_name
"description" = var.description
output "network_interface_name" {
value = "${azurerm_network_interface.nic.id}"
}
triggers = {
folders = "${local.folders}",
container = "${azurerm_storage_container.main.name}"
}'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end