package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)"\$\{([a-zA-Z0-9_.]+)\}"`)
var str = ` "EncryptionOperation": "EnableEncryption",
"KeyVaultURL": "${data.azurerm_key_vault.disk.0.vault_uri}",
"KeyVaultResourceId": "${var.key_vault_id}",
"KeyEncryptionAlgorithm": "RSA-OAEP",
"VolumeType": "All"
"hostname" = var.host_name
"description" = var.description
output "network_interface_name" {
value = "${azurerm_network_interface.nic.id}"
}
triggers = {
folders = "${local.folders}",
container = "${azurerm_storage_container.main.name}"
}`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}