// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)"\$\{([a-zA-Z0-9_.]+)\}""#).unwrap();
let string = " \"EncryptionOperation\": \"EnableEncryption\",
\"KeyVaultURL\": \"${data.azurerm_key_vault.disk.0.vault_uri}\",
\"KeyVaultResourceId\": \"${var.key_vault_id}\",
\"KeyEncryptionAlgorithm\": \"RSA-OAEP\",
\"VolumeType\": \"All\"
\"hostname\" = var.host_name
\"description\" = var.description
output \"network_interface_name\" {
value = \"${azurerm_network_interface.nic.id}\"
}
triggers = {
folders = \"${local.folders}\",
container = \"${azurerm_storage_container.main.name}\"
}";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}