import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\"\\$\\{([a-zA-Z0-9_.]+)\\}\"";
final String string = " \"EncryptionOperation\": \"EnableEncryption\",\n"
+ " \"KeyVaultURL\": \"${data.azurerm_key_vault.disk.0.vault_uri}\",\n"
+ " \"KeyVaultResourceId\": \"${var.key_vault_id}\",\n"
+ " \"KeyEncryptionAlgorithm\": \"RSA-OAEP\",\n"
+ " \"VolumeType\": \"All\"\n\n"
+ " \"hostname\" = var.host_name\n"
+ " \"description\" = var.description\n\n"
+ "output \"network_interface_name\" {\n"
+ " value = \"${azurerm_network_interface.nic.id}\"\n"
+ "}\n\n"
+ " triggers = {\n"
+ " folders = \"${local.folders}\",\n"
+ " container = \"${azurerm_storage_container.main.name}\"\n"
+ " }";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}