using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"""\$\{([a-zA-Z0-9_.]+)\}""";
string input = @" ""EncryptionOperation"": ""EnableEncryption"",
""KeyVaultURL"": ""${data.azurerm_key_vault.disk.0.vault_uri}"",
""KeyVaultResourceId"": ""${var.key_vault_id}"",
""KeyEncryptionAlgorithm"": ""RSA-OAEP"",
""VolumeType"": ""All""
""hostname"" = var.host_name
""description"" = var.description
output ""network_interface_name"" {
value = ""${azurerm_network_interface.nic.id}""
}
triggers = {
folders = ""${local.folders}"",
container = ""${azurerm_storage_container.main.name}""
}";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}