import Foundation
let pattern = #""\$\{([a-zA-Z0-9_.]+)\}""#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
"EncryptionOperation": "EnableEncryption",
"KeyVaultURL": "${data.azurerm_key_vault.disk.0.vault_uri}",
"KeyVaultResourceId": "${var.key_vault_id}",
"KeyEncryptionAlgorithm": "RSA-OAEP",
"VolumeType": "All"
"hostname" = var.host_name
"description" = var.description
output "network_interface_name" {
value = "${azurerm_network_interface.nic.id}"
}
triggers = {
folders = "${local.folders}",
container = "${azurerm_storage_container.main.name}"
}
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)