# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\"\$\{([a-zA-Z0-9_.]+)\}\""
test_str = (" \"EncryptionOperation\": \"EnableEncryption\",\n"
" \"KeyVaultURL\": \"${data.azurerm_key_vault.disk.0.vault_uri}\",\n"
" \"KeyVaultResourceId\": \"${var.key_vault_id}\",\n"
" \"KeyEncryptionAlgorithm\": \"RSA-OAEP\",\n"
" \"VolumeType\": \"All\"\n\n"
" \"hostname\" = var.host_name\n"
" \"description\" = var.description\n\n"
"output \"network_interface_name\" {\n"
" value = \"${azurerm_network_interface.nic.id}\"\n"
"}\n\n"
" triggers = {\n"
" folders = \"${local.folders}\",\n"
" container = \"${azurerm_storage_container.main.name}\"\n"
" }")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.