const regex = /"\$\{([a-zA-Z0-9_.]+)\}"/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('"\\$\\{([a-zA-Z0-9_.]+)\\}"', 'gm')
const str = ` "EncryptionOperation": "EnableEncryption",
"KeyVaultURL": "\${data.azurerm_key_vault.disk.0.vault_uri}",
"KeyVaultResourceId": "\${var.key_vault_id}",
"KeyEncryptionAlgorithm": "RSA-OAEP",
"VolumeType": "All"
"hostname" = var.host_name
"description" = var.description
output "network_interface_name" {
value = "\${azurerm_network_interface.nic.id}"
}
triggers = {
folders = "\${local.folders}",
container = "\${azurerm_storage_container.main.name}"
}`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}