$re = '/"\$\{([a-zA-Z0-9_.]+)\}"/m';
$str = ' "EncryptionOperation": "EnableEncryption",
"KeyVaultURL": "${data.azurerm_key_vault.disk.0.vault_uri}",
"KeyVaultResourceId": "${var.key_vault_id}",
"KeyEncryptionAlgorithm": "RSA-OAEP",
"VolumeType": "All"
"hostname" = var.host_name
"description" = var.description
output "network_interface_name" {
value = "${azurerm_network_interface.nic.id}"
}
triggers = {
folders = "${local.folders}",
container = "${azurerm_storage_container.main.name}"
}';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);