# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?<!\d)-(?=\d)/~/gm;t' <<< "7+6+-7
6 - -12
-12 - -11
1--2
-1--2
4*-5
-4/-4"