use strict;
my $str = '7+6+-7
6 - -12
-12 - -11
1--2
-1--2
4*-5
-4/-4';
my $regex = qr/(?<!\d)-(?=\d)/mp;
my $subst = '~';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";