import Foundation
let pattern = #"(?<!\d)-(?=\d)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
7+6+-7
6 - -12
-12 - -11
1--2
-1--2
4*-5
-4/-4
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"~"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)