using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<!\d)-(?=\d)";
string substitution = @"~";
string input = @"7+6+-7
6 - -12
-12 - -11
1--2
-1--2
4*-5
-4/-4";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}