#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(?<!\d)-(?=\d)"
Local $sString = "7+6+-7" & @CRLF & _
"6 - -12" & @CRLF & _
"-12 - -11" & @CRLF & _
"1--2" & @CRLF & _
"-1--2" & @CRLF & _
"4*-5" & @CRLF & _
"-4/-4"
Local $sSubst = "~"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)