import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<!\\d)-(?=\\d)";
final String string = "7+6+-7\n"
+ "6 - -12\n"
+ "-12 - -11\n"
+ "1--2\n"
+ "-1--2\n"
+ "4*-5\n"
+ "-4/-4";
final String subst = "~";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}