# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^(?:\s*(?:Dr[sa]?|Prof|M\.Ag|M[EM])\.?)+\s*|\s*,(?:\s*(?:Dr[sa]?|Prof|M\.Ag|M[EM])\.?)+$//gm;t' <<< "Dr. RICHARD, MM
Dr. BOBBY Richard Klaus, MM
Richard, MM"