$re = '/^(?:\s*(?:Dr[sa]?|Prof|M\.Ag|M[EM])\.?)+\s*|\s*,(?:\s*(?:Dr[sa]?|Prof|M\.Ag|M[EM])\.?)+$/m';
$str = 'Dr. RICHARD, MM
Dr. BOBBY Richard Klaus, MM
Richard, MM';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;