const regex = new RegExp('^(?:\\s*(?:Dr[sa]?|Prof|M\\.Ag|M[EM])\\.?)+\\s*|\\s*,(?:\\s*(?:Dr[sa]?|Prof|M\\.Ag|M[EM])\\.?)+$', 'gm')
const str = `Dr. RICHARD, MM
Dr. BOBBY Richard Klaus, MM
Richard, MM`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);