use strict;
my $str = 'Dr. RICHARD, MM
Dr. BOBBY Richard Klaus, MM
Richard, MM';
my $regex = qr/^(?:\s*(?:Dr[sa]?|Prof|M\.Ag|M[EM])\.?)+\s*|\s*,(?:\s*(?:Dr[sa]?|Prof|M\.Ag|M[EM])\.?)+$/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";