import Foundation
let pattern = #"^(?:\s*(?:Dr[sa]?|Prof|M\.Ag|M[EM])\.?)+\s*|\s*,(?:\s*(?:Dr[sa]?|Prof|M\.Ag|M[EM])\.?)+$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
Dr. RICHARD, MM
Dr. BOBBY Richard Klaus, MM
Richard, MM
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)