package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?:\s*(?:Dr[sa]?|Prof|M\.Ag|M[EM])\.?)+\s*|\s*,(?:\s*(?:Dr[sa]?|Prof|M\.Ag|M[EM])\.?)+$`)
var str = `Dr. RICHARD, MM
Dr. BOBBY Richard Klaus, MM
Richard, MM`
var substitution = ""
fmt.Println(re.ReplaceAllString(str, substitution))
}