re = /^(?:\s*(?:Dr[sa]?|Prof|M\.Ag|M[EM])\.?)+\s*|\s*,(?:\s*(?:Dr[sa]?|Prof|M\.Ag|M[EM])\.?)+$/m
str = 'Dr. RICHARD, MM
Dr. BOBBY Richard Klaus, MM
Richard, MM'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result