import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:\\s*(?:Dr[sa]?|Prof|M\\.Ag|M[EM])\\.?)+\\s*|\\s*,(?:\\s*(?:Dr[sa]?|Prof|M\\.Ag|M[EM])\\.?)+$";
final String string = "Dr. RICHARD, MM\n"
+ "Dr. BOBBY Richard Klaus, MM\n"
+ "Richard, MM";
final String subst = "";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}