import re
regex = re.compile(r"^(?:\s*(?:Dr[sa]?|Prof|M\.Ag|M[EM])\.?)+\s*|\s*,(?:\s*(?:Dr[sa]?|Prof|M\.Ag|M[EM])\.?)+$", flags=re.MULTILINE)
test_str = ("Dr. RICHARD, MM\n"
"Dr. BOBBY Richard Klaus, MM\n"
"Richard, MM")
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)