#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)<a[\S\s]+?<\/a>(*SKIP)(*FAIL)|\bas\b"
Local $sString = "class" & @CRLF & _
"bass" & @CRLF & _
"taste" & @CRLF & _
"as" & @CRLF & _
"as in there are" & @CRLF & _
"<a href="as.php">a link as a nother thing</a>" & @CRLF & _
"as in none link"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")