re = /<a[\S\s]+?<\/a>(*SKIP)(*FAIL)|\bas\b/m
str = 'class
bass
taste
as
as in there are
<a href="as.php">a link as a nother thing</a>
as in none link'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end