$re = '/<a[\S\s]+?<\/a>(*SKIP)(*FAIL)|\bas\b/m';
$str = 'class
bass
taste
as
as in there are
<a href="as.php">a link as a nother thing</a>
as in none link';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);