import re
regex = re.compile(r"<a[\S\s]+?<\/a>(*SKIP)(*FAIL)|\bas\b", flags=re.MULTILINE)
test_str = ("class\n"
"bass\n"
"taste\n"
"as\n"
"as in there are\n"
"<a href=\"as.php\">a link as a nother thing</a>\n"
"as in none link")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")