import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<a[\\S\\s]+?<\\/a>(*SKIP)(*FAIL)|\\bas\\b";
final String string = "class\n"
+ "bass\n"
+ "taste\n"
+ "as\n"
+ "as in there are\n"
+ "<a href=\"as.php\">a link as a nother thing</a>\n"
+ "as in none link";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}