// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)<a[\S\s]+?<\/a>(*SKIP)(*FAIL)|\bas\b").unwrap();
let string = "class
bass
taste
as
as in there are
<a href=\"as.php\">a link as a nother thing</a>
as in none link";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}