use strict;
my $str = 'class
bass
taste
as
as in there are
<a href="as.php">a link as a nother thing</a>
as in none link';
my $regex = qr/<a[\S\s]+?<\/a>(*SKIP)(*FAIL)|\bas\b/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}