using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<a[\S\s]+?<\/a>(*SKIP)(*FAIL)|\bas\b";
string input = @"class
bass
taste
as
as in there are
<a href=""as.php"">a link as a nother thing</a>
as in none link";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}