# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/-[^-]*$|:[^:\n]*$//gm;t' <<< "ABCDEF
FEDCBA:XA
AA-BB-CCCC-01
AA-BB-CCCC-21:ABC
ABCDEFGH-IJK-1X"