package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)-[^-]*$|:[^:\n]*$`)
var str = `ABCDEF
FEDCBA:XA
AA-BB-CCCC-01
AA-BB-CCCC-21:ABC
ABCDEFGH-IJK-1X`
var substitution = ""
fmt.Println(re.ReplaceAllString(str, substitution))
}