import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "-[^-]*$|:[^:\\n]*$";
final String string = "ABCDEF\n"
+ "FEDCBA:XA\n"
+ "AA-BB-CCCC-01\n"
+ "AA-BB-CCCC-21:ABC\n"
+ "ABCDEFGH-IJK-1X";
final String subst = "";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}