#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)-[^-]*$|:[^:\n]*$"
Local $sString = "ABCDEF" & @CRLF & _
"FEDCBA:XA" & @CRLF & _
"AA-BB-CCCC-01" & @CRLF & _
"AA-BB-CCCC-21:ABC" & @CRLF & _
"ABCDEFGH-IJK-1X"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)