re = /-[^-]*$|:[^:\n]*$/m
str = 'ABCDEF
FEDCBA:XA
AA-BB-CCCC-01
AA-BB-CCCC-21:ABC
ABCDEFGH-IJK-1X'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result