use strict;
my $str = 'ABCDEF
FEDCBA:XA
AA-BB-CCCC-01
AA-BB-CCCC-21:ABC
ABCDEFGH-IJK-1X';
my $regex = qr/-[^-]*$|:[^:\n]*$/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";