import re
regex = re.compile(r"-[^-]*$|:[^:\n]*$", flags=re.MULTILINE)
test_str = ("ABCDEF\n"
"FEDCBA:XA\n"
"AA-BB-CCCC-01\n"
"AA-BB-CCCC-21:ABC\n"
"ABCDEFGH-IJK-1X")
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)